[Usuarios RCSL] Error al hacer apt-get dist-upgrade

Leo Arias F. elopio en softwarelibrecr.org
Mar Ene 27 21:49:43 CST 2009


2008/11/20 Cris Montoya <elcuminate en gmail.com>:
> Hola, me topé con algo que no tengo idea qué es...
>
> Tratando de hacer apt-get dist-upgrade recibí este error:
>
> Desinstalando linux-restricted-modules-2.6.27-7-generic ...
> rmdir: No se pudo eliminar «/lib/modules/2.6.27-7-generic/volatile/»:
> No existe el fichero ó directorio
> FATAL: Could not open '/boot/System.map-2.6.27-7-generic': No such
> file or directory
> update-initramfs: Generating /boot/initrd.img-2.6.27-7-generic
> Cannot find /lib/modules/2.6.27-7-generic
> update-initramfs: failed for /boot/initrd.img-2.6.27-7-generic
> dpkg: error al procesar linux-restricted-modules-2.6.27-7-generic (--remove):
>  el subproceso post-removal script devolvió el código de salida de error 1
> Se encontraron errores al procesar:
>  linux-restricted-modules-2.6.27-7-generic
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> Gracias...

Ya solucionamos esto. No se si fue de la mejor forma, pero no
encontramos nada sobre el error que funcionara. En algún lado
sugirieron engañar a dpkg creando los archivos que no encontraba, y
así ya funcionó.
Creo que quedó en todas, espero que esto no cause algún problema nuevo.

-- 
Leo Arias
http://elopio.net



Más información sobre la lista de distribución Usuarios